Skip to main content

            

International Newspapers and Magazines: New York Times

App for NYT

Click here to Install Android and iPhone/IPad

For iOS:- Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

For Android:- Requires 4.4 and up

Note: Once registration is done on campus, the same credentials will be used for mobile apps as well. It is accessible, if person is not within the range of our set Ips.